KDSmart Version 3 Changes

This topic describes the major changes in KDSmart Version 3.0 which reached production status on 28th April 2018.


What’s New In Release 3.0

KDSmart Version 3.0 introduces a number of new features aimed to further assist making scoring in the field easier. We are grateful to all the feedback and suggestions from our users. Some of the following improvements are as a direct response to user suggestions.

This topic provides an overview of some of the main new features, namely:

  • A New Home Screen - more information at hand;
  • The Spreadsheet View – underlying functionality is still the same as for Trial Scoring;
  • Add Trait Instances - Easy to add or remove Trait Instances to a Trial;
  • New Trait and Tag Bundles - for easier management; and
  • Progress Tracking for all Trials - (Samples Scored / Total Number of Samples).


The Main Window

The Main or Home window has undergone changes to include more Trial/Nursery information for the selected Trial without need to first visit the Trials window.

Features of the updated Main window include:

  • Scroll through the Trial/Nurseries in KDSmart by swiping left or right in the main window.

  • Page indicator bars, above the Trial Name field, indicate current position in the ‘list of Trials’ and whether scrolling left or right will reveal more Trial/Nurseries.

  • Restarting KDSmart or returning to the Main window will display the name of the last Trial displayed (possibly the last being scored).

  • The Main Window Play button image0 now has dual functions:

    Long Press

    Displays the Configure Trial window

    Single Tap
    • Recommence interrupted scoring for a Trial; or
    • Display the Configure Trial window if the Trial is yet to be scored.
  • For the displayed Trial, using the top ‘Play’ image0 button recommences scoring from the last Plot or position where scoring stopped.

  • The Scoring Progress Bar provides a quick visual guide for the displayed Trial/Nursery.

  • The new Trial Details button is a fastpath to the details of the displayed Trial/Nursery.

  • When screen space is limited, e.g. with a phone, the bottom primary function button bar for Trials, Traits, Tags, etc. now has left/right scrolling to reveal any additional function buttons.

The New Main Window (Select to zoom)


The Spreadsheet View

Spreadsheet View is a new option in Version 3.0 for scoring providing a ‘spreadsheet style’ view of a Trial/Nursery. Some scoring situations will benefit from this alternative to the original and default Path view. It is easy to alternate between the two as views as your needs dictate in the field.

The following illustration shows the Spreadsheet View Scoring window (no scored traits visible):

The Spreadsheet View Menu (Select to zoom)


Note

When first selecting Spreadsheet View the first column is partially collapsed, designed to accomodate small phone screens. It can easily be adjusted by:

  1. Selecting the menu image2 button at top right.
  2. Select Adjust First Column Width to display a sizing slider at the bottom of the window.
  3. Adjust the width as required then switch of th resizer by deselecting the Adjust First Column Width menu item.


How to Select Spreadsheet View

Spreadsheet View can be selected in the Trial Details Configure Options window for a Trial as illustrated next.

Note: In Settings the default view, Spreadsheet or Path can be set.

View Selection (Select to zoom)


Spreadsheet View Window Elements

The following image shows a cropped and annotated version of the previous example Spreadsheet View.
A description of the window elements is provided in the following table.

Annotated Spreadsheet View (Select to zoom)


Annotations for the illustration above
Item Description
Select the location goto-btn button to return to the last scored sample.
Active Trait columns, scrollable left to right.
Note: Traits that are inactive for the scoring session are not displayed.
The plot identifier/coordinate column, i.e. Plot ID/ Column, Row.
Also shows indicators for Tags, Notes, Photos and menu selector.
Symbolises the Plot. Downward pointing a-npc-btn indicates the Plot is expanded displaying the contained Sub-Plots. Sideways pointing a-pc-btn indicates the Sub-Plots for the plot are hidden from view.
A Sub-Plot belonging to the plot above.
The dash ‘-‘ symbolises an un-scored Trait. Touch the cell to score the Trait for this plot.
The dot ‘.’ Symbolises a value cannot be entered e.g. this is a plot level trait. In this example it is a plot level trait and it is at the Sub-Plot row, hence not scorable.
Green arrow indicates Plots are vertically scrollable.
Yellow arrow indicates the Traits are horizontally scrollable.
Blue arrow indicates this area can be expanded or contracted by selecting Adjust First Column Width from the Spreadsheet View menu (11) then using the resizing bar.
The Spreadsheet View Menu. See the Spreadsheet View Menu Options topic below.

To enter or replace a score for a Sub-Plot touch the required row and column position for the Trait. The displayed dialog is dependent upon the Trait’s data type, e.g. the following example is for a Date Data Type.

Note: Entry of Trait values is the same for both Spreadsheet and Path views.

Date Data Type Trait Entry (Select to zoom)


Note: If the Lock Scored Traits option is enabled, subsequent attempts to edit the existing value will display a warning with option to continue or stop to prevent accidental changes as illustrated next.

Trait Already Set (Select to zoom)


TraitLevels

Previously TraitLevels could only be specified as either Plot or Sub-Plot.
With KSDSmart version 3.0.3 TraitLevel can be set to:

Plot Level
by using “Plot” or “TrialUnit”; or
Sub-Plot Level
by using “Sub-Plot”, “Individual” or “Plant”.


Trait Instances

Trait Instances can be added to a Trial when viewing the Traits for a Trial. In the following example the addto button has been selected to reveal the highlighted menu.

Trait Instance Menu (Select to zoom)


The menu options for Trait Instances, as appearing in the above illustration, are:

Item Description
Add Instance A new instance can be added to a Trait which is associated with the Trial.
Trait instances appear with naming of #1, #2, #3, etc.
Move Up/Down A Trait, always with it’s instances, can be moved up or down relative to other Traits.
By default the Traits appear in alphabetic order.
Edit Description The description for the Trait Instance can be edited.
The pencil button edit appears next to a Trait Instance to perform this.
Remove Trait A Trait or a Trait Instance can be removed from a Trial only if it is not scored.
Use the pencil button edit adjacent to the Trait Instance to remove the Trait.

Note

Adding a Trait Instance following the removal of a Trait Instance
In a situation of multiple Trait Instances, e.g. #1, #2 and #3, the removal of #1 from a Trial will leave Instances #2 and #3. If an Instance is added it will be Instance #4 (i.e. #1 is not replaced).
However, in this example, if #3 is removed, then and Instance is added it will be #3.
Remember an instance cannot be removed if it contains any scored values.


Displaying Trait Attributes

Touching the Trait Name at the top of the trait column displays the Trait’s Attributes. These include Trait:

  • Alias;
  • Description;
  • Datatype;
  • Validation Rule;
  • Units; and
  • Level.

The following illustration from Spreadsheet view shows the Trait DFF_PLOT (at ‘1’) was touched to display the highlighted information:

Trait Attributes Display (Select to zoom)


Additional Plot or Sub-Plot Attributes and Actions

A Short Press on the plot or Sub-Plot identifier/coordinate displays the plot or Sub-Plot attributes.

Plot Attributes Display (Select to zoom)

A Long Press on the plot or Sub-Plot identifier/coordinate displays further attributes and functions. These are:

  • Deactivate or Activate the plot/Sub-Plot;
  • View, Add or Remove Tags;
  • Add a Note (typed entry) for the plot/Sub-Plot;
  • Add Photos;
  • Add an Audio note; and
  • Add a Sub-Plot to the plot.

Note: Depending on the Android version in use on the device, KDSmart must be given permission to use the camera or microphone.

The following example shows the Sub-Plot has two tags assigned, ‘GV+++’ and ‘MD’ and no images are attached, as the attachment icon is greyed out.

Long Press (Select to zoom)


With attributes displayed as in the above example, a short press of either the plot/Sub-Plot icon or identifier/coordinate will display the menu which are both illustrated below.

Plot Menu Sub-Plot Menu


Spreadsheet View Menu Options

Selecting the top right Menu button image2 in Spreadsheet View displays a menu as illustrated. See the following table for a brief description of these menu options:

The Spreadsheet View (Select to zoom)


Item Description
Text Size Adjust the text size of the sample values.
Adjust First Column Width Displays a slider at the bottom of screen allowing adjustment of the first column width which is helpful for small phone screens with limited space.
Location Enable or Disable location services.
Scanner On Displays the Paired Devices window to allow connecting or reconnecting to a scanner.
Configure Configure the information to appear in the Plot Attributes.
Elapsed Days Count Checkbox to change the display of Elapsed Days from a Date to the Number of Days since the Trial planting date.
Unlock Scored Traits Unlocks scored Traits, enabling modification without warning step.
Change Screen Orientation Change the screen orientation, e.g. change from Landscape to Portrait. A three second delay allows the tablet to be turned to the desired orientation before the rotation lock is reactivated.
Choose Plot Colours Three colours are available for Plots and Traits and more can be added on request.
Show/Hide Sub-Plots Hides or Shows all the Sub-Plots, useful for scoring only Plot Traits.
Fixed Plot Info Enables selection for column display of inactive Traits and Plot Attributes.
Help Displays the in built KDSmart help.


Trait and Tag Bundles

Trait and Tag Bundles are a mechanism for grouping them. This may assist with their use and management, e.g. it maybe helpful to Bundle Traits for a type of crop, season or a specific experiment. Also they can assist with distribution to multiple KDSmart devices for efficiency and to ensure consistency.

Some features of Bundles are:

  • A Trait or Tag can exist in multiple Bundles;
  • Every Trait or Tag is a member of the ‘All Traits’ or ‘All Tags’ Bundles;
  • Bundles make selection of Traits or Tags easier for export or import;
  • Traits or Tags can be added or removed from Bundles (except All Traits or All Tags);
  • It is easy to select multiple Traits/Tags and create a new Bundle; and
  • Bundles can be deleted, except for the All Trait and All Tag Bundles.

The example below shows a Trait Bundle named ‘Dates Bundle’ expanded to show the contents. Note the circled number, at right of the Bundle name, indicating it contains ten Traits. When expanded the Traits in the Bundle appear below the Bundle name (dotted highlight).

Trait Bundle (Select to zoom)

Remember Bundles are logical groupings, so there is only ever one instance of a Trait defined in KDSmart.

Note: for Bundles, Tags work in the same manner as Traits.


Creating Bundles

Viewing Traits or Tags the procedure is the same. Traits are used here to illustrate.

Note: To create a Bundle at least one Trait or Tag needs to be selected to invoke the menu, however a Bundle can exist without Traits/Tags.

A long press on a Trait will reveal a different set of actions

Example of Trait Menu Bar on different sized devices
Tablet Phone
Tablet Example (Select to zoom)
Phone Example (Select to zoom)
Steps to Create, Add to or Delete from a Bundle
Step Action
In the Trait/Tag Window Long Press a Trait/Tag to be added to the Bundle.
The top bar of the display will change to be similar to the previous Trait window examples for phone and tablet. This also indicates the number of Traits/Tags selected.
More Traits/Tags can be selected or deselected with a single press.
Select either the Menu button image2 or the Trait Bundle trait_b-btn or Tag Bundle tag_b-btn button.
Enter a unique Bundle name. The display will assist providing a unique name.
Select the Create/Add button to create the new Bundle or if Delete has been selected confirm by selecting the Delete button.
Note: Deleting a Bundle does not delete the Traits.


Export Bundles

Bundles can be exported as either a CSV file or to KDXplore which will require a connection.

Steps to Export a Bundle
Step Action
In the Trait/Tag Window Long Press the Bundle to be exported.
At the top bar of the display select the Export button upload_btn.
Select Tablet to export a CSV file or KDXplore if you have a current connection to the KDXplore application.
Confirm and a message will indicate success and location of the CSV file.